-
使用证书建立ssl安全连接
资源描述socket连接,使用ssl建立安全通道,传输数据,压缩包括里面包含client和server及相关证书。
目录结构:
gen_ca.sh: used to generate a ca cert
gen_subcert.sh: used to generate a sub cert from ca
Makefile: used to generate app_client and app_server by client.c and server.c
client.c:the client use ssl to transfer data
server.c: the server use ssl to transfer data
- 2022-02-25 14:06:16下载
- 积分:1
-
动态域名基础知识
什么是IP地址
IP地址是在网络上分配给每台计算机或网络设备的32位数字标识。在Internet上,每台计算机或...
动态域名基础知识
什么是IP地址
IP地址是在网络上分配给每台计算机或网络设备的32位数字标识。在Internet上,每台计算机或网络设备的IP地址是全世界唯一的。IP地址的格式是 xxx.xxx.xxx.xxx,其中xxx是 0 到 255 之间的任意整数。例如,科迈网站主机的IP地址是 210.22.12.54。 -dynamic domain knowledge what is the basis of IP addresses in the IP network addresses are assigned to each computer or network equipment of the 32-digit identification. On the Internet, every computer equipment or network is the IP address of the world only. IP addresses xxx.xxx.xxx.xxx is the format, which is xxx 0-255 between the arbitrary integer. For example, Comay website host IP address is 210.22.12.54.
- 2022-02-03 06:22:12下载
- 积分:1
-
LINUX套接字网络编程的小代码!
LINUX套接字网络编程的小代码!-LINUX sleeve joint character network programming small code!
- 2022-02-03 13:36:47下载
- 积分:1
-
浏览器
基于浏览器的网络邮件程序客户端软件 > 支持MIME邮件格式RFC2045,RFC2046,RFC2047 > 支持邮件内图像格式image/jpeg,image/gif > 支持在单页内显示message/rfc822,message/digest > 运用了新颖的立即算法,邮件处理更快速,高效 > 支持附件传送 -browser-based Web mail Client Software gt; Mail MIME format support RFC2045 and RFC2046 and RFC2047 gt; Supported image formats mail within the image/jpeg, image/gif gt; Support for the single-page display message/rfc822, message/data gt; Use a novel algorithm immediately, mail handling more rapid, efficient gt; support Annex transmission
- 2022-03-15 02:25:29下载
- 积分:1
-
- 2022-08-16 17:52:28下载
- 积分:1
-
简单的客户端和服务器
资源描述简单的代码,基本实现连接客户端和服务器,带有多线程,运用套接字网络编程技术,代码简单,适合初接触网络编程的学习
- 2023-03-16 03:10:04下载
- 积分:1
-
。net学习中关于WebParts的小例子
。net学习中关于WebParts的小例子-. net to learn on a small example of WebParts
- 2022-10-13 07:55:02下载
- 积分:1
-
实现了基本的网络的通讯,这是很基本的,也许有点简单,但希望多少能给你点帮助...
实现了基本的网络的通讯,这是很基本的,也许有点简单,但希望多少能给你点帮助-The basic implementation of the communications network, which is very basic, perhaps a bit simple, but how can you hope to help the
- 2022-03-17 23:41:45下载
- 积分:1
-
P2P文件共享
实现P2P文件共享,包括5个peer和一个file owner,五个peer从file owner处获取一部分文件,然后五个peer建立拓扑图,实现文件共享
- 2022-07-26 20:26:22下载
- 积分:1
-
Delphi Socket服务端与客户端
Delphi Socket服务端与客户端源码,服务端与客户端相互传输信息,可以做IM类通讯软件
- 2022-04-10 14:34:38下载
- 积分:1